summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-02 23:54:00 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-02 23:54:00 -0400
commit202288be83b56a724c316ce0ad2fcb41bd63f0eb (patch)
tree8e65e76974cd8933587c75f4bd12cbaee74e2005 /Makefile.am
parent7d617113eeafa5d7f7cc2994a81ec6b2a54481b3 (diff)
build-sys: tell rsync no to tranfer times and permissions
When rsyncing to fd.o, rsync would fail on symlinks in man/. We don't care about the times too much anyway. rsync will set times to "now", which is fine, since modification times don't matter much outside of each uploader's machine anyway. The point is to complete all steps of the transfer, so Python documentation is properly updated.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4040a8529..d4c2f8577 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4161,11 +4161,11 @@ upload: all distcheck
www_target = www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd
doc-sync: all destdir-sphinx
gtkdoc-rebase --html-dir=docs/libudev/html --online
- rsync -av --delete docs/libudev/html/ --omit-dir-times $(www_target)/libudev/
+ rsync -rlv --delete docs/libudev/html/ --omit-dir-times $(www_target)/libudev/
gtkdoc-rebase --html-dir=docs/gudev/html --online
- rsync -av --delete docs/gudev/html/ --omit-dir-times $(www_target)/gudev/
- rsync -av --delete-excluded --include="*.html" --exclude="*" --omit-dir-times man/ $(www_target)/man/
- rsync -av --delete --omit-dir-times docs/html/python-systemd/ $(www_target)/python-systemd/
+ rsync -rlv --delete docs/gudev/html/ --omit-dir-times $(www_target)/gudev/
+ rsync -rlv --delete-excluded --include="*.html" --exclude="*" --omit-dir-times man/ $(www_target)/man/
+ rsync -rlv --delete --omit-dir-times docs/html/python-systemd/ $(www_target)/python-systemd/
git-tag:
git tag "v$(VERSION)" -m "systemd $(VERSION)"