summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-02-27 18:50:41 +0100
committerLennart Poettering <lennart@poettering.net>2013-02-27 18:50:41 +0100
commit26d04f86a36595e3565c74d67863e076c3e3c773 (patch)
tree374ba1bdf5dfc95a9c05df1232ffc44d8bd98397 /Makefile.am
parent416389f7ae262ae7a0848302e7a6516597f9fad1 (diff)
unit: rework resource management API
This introduces a new static list of known attributes and their special semantics. This means that cgroup attribute values can now be automatically translated from user to kernel notation for command line set settings, too. This also adds proper support for multi-line attributes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 74534cce8..2108abe31 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -852,6 +852,8 @@ libsystemd_core_la_SOURCES = \
src/core/tcpwrap.h \
src/core/cgroup-attr.c \
src/core/cgroup-attr.h \
+ src/core/cgroup-semantics.c \
+ src/core/cgroup-semantics.h \
src/core/securebits.h \
src/core/initreq.h \
src/core/special.h \