summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-27 12:12:07 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-06-30 18:39:45 -0400
commit2968644080fd103062f070e83edd620e0a58c44d (patch)
tree23eb479af49fa71966b565dea7f29a2e2eb130e2 /Makefile.am
parent6e81b5b9dc10dd0b47102afe42457e4a314cb01f (diff)
Move x-systemd-device.timeout handling from core to fstab-generator
Instead of adjusting job timeouts in the core, let fstab-generator write out a dropin snippet with the appropriate JobTimeout. x-systemd-device.timeout option is removed from Options= line in the generated unit. The functions to write dropins are moved from core/unit.c to shared/dropin.c, to make them available outside of core. generator.c is moved to libsystemd-label, because it now uses functions defined in dropin.c, which are in libsystemd-label.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 60f69fe32..783f5fe18 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -816,8 +816,6 @@ libsystemd_shared_la_SOURCES = \
src/shared/bus-label.c \
src/shared/bus-label.h \
src/shared/gpt.h \
- src/shared/generator.h \
- src/shared/generator.c \
src/shared/clean-ipc.h \
src/shared/clean-ipc.c \
src/shared/login-shared.c \
@@ -874,7 +872,11 @@ libsystemd_label_la_SOURCES = \
src/shared/fileio-label.c \
src/shared/fileio-label.h \
src/shared/dev-setup.c \
- src/shared/dev-setup.h
+ src/shared/dev-setup.h \
+ src/shared/dropin.c \
+ src/shared/dropin.h \
+ src/shared/generator.h \
+ src/shared/generator.c
libsystemd_label_la_CFLAGS = \
$(AM_CFLAGS) \