summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2012-12-22 10:09:23 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-01-04 22:20:35 -0500
commit2f4da3e6c298bc0ae6243cae47aedb01c50fa870 (patch)
treea83c692516fdafd779efd64e743b6cb273eb7da1 /Makefile.am
parentbbed6c0d4b54d9c4e510415770e091d79eee2e8e (diff)
systemd-analyze: use specified binary, add --version
Python binary used in the she-bang line in installed scripts can be set with ./configure PYTHON_BINARY=... Defaults to the same path as python used during compilation. Adding --version makes systemd-analyze behave consistently with the rest of installed programs. The lines in ./configure output are reordered to keep all yes/no lines separate. I think that this makes the output clearer.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c5af8e813..e81998d3b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3803,6 +3803,8 @@ SED_PROCESS = \
-e 's,@VARLOGDIR\@,$(varlogdir),g' \
-e 's,@RC_LOCAL_SCRIPT_PATH_START\@,$(RC_LOCAL_SCRIPT_PATH_START),g' \
-e 's,@RC_LOCAL_SCRIPT_PATH_STOP\@,$(RC_LOCAL_SCRIPT_PATH_STOP),g' \
+ -e 's,@PYTHON\@,$(PYTHON),g' \
+ -e 's,@PYTHON_BINARY\@,$(PYTHON_BINARY),g' \
< $< > $@
units/%: units/%.in Makefile