summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSusant Sahani <susant@redhat.com>2014-07-03 13:34:11 +0530
committerTom Gundersen <teg@jklm.no>2014-07-03 11:00:02 +0200
commit30ae9dfda3788cdfaf1b84d124dbc7feb638c77b (patch)
tree854a45b96eb6cd48b9b2caed95a1ecb23de7b2ed /Makefile.am
parent866ee3682213789f85b877700457fdca05695a0e (diff)
networkd: Introduce tun/tap device
This patch introduces TUN/TAP device creation support to networkd. Example conf to create a tap device: file: tap.netdev ------------------ [NetDev] Name=tap-test Kind=tap [Tap] OneQueue=true MultiQueue=true PacketInfo=true User=sus Group=sus ------------------ Test: 1. output of ip link tap-test: tap pi one_queue UNKNOWN_FLAGS:900 user 1000 group 1000 id: uid=1000(sus) gid=10(wheel) groups=10(wheel),1000(sus) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 Modifications: Added: 1. file networkd-tuntap.c 3. netdev kind NETDEV_KIND_TUN and NETDEV_KIND_TAP 2. Tun and Tap Sections and config params to parse conf and gperf conf parameters [tomegun: tweak the 'kind' checking for received ifindex]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cc3b7fd5d..672e93f16 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4535,6 +4535,7 @@ libsystemd_networkd_core_la_SOURCES = \
src/network/networkd-vlan.c \
src/network/networkd-macvlan.c \
src/network/networkd-dummy.c \
+ src/network/networkd-tuntap.c \
src/network/networkd-network.c \
src/network/networkd-address.c \
src/network/networkd-route.c \