summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-01-23 23:34:36 +0100
committerLennart Poettering <lennart@poettering.net>2012-01-23 23:34:36 +0100
commit36db9a8d5b36173daf1f622fb544f4c90cfddb67 (patch)
tree3c03fb457b1ae276952db3758731f575859898f9 /Makefile.am
parent36e43bddd0a4526e77cdae2c922bb29f67bd74ad (diff)
login: add multi-session X wrapper
In preparation for https://bugzilla.gnome.org/show_bug.cgi?id=655380 we decided it's better to include the multi-seat X wrapper in systemd, rather than gdm. (Side effect: this makes this accessible for other DMs) This is a stop-gap for now, until X gins proper multi-seat graphics support at which point this code will go away without replacement.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1df603ba6..d6fcd2382 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -99,6 +99,7 @@ AM_CPPFLAGS = \
-DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \
-DSYSTEM_SHUTDOWN_PATH=\"$(systemshutdowndir)\" \
-DSYSTEMD_KBD_MODEL_MAP=\"$(pkgdatadir)/kbd-model-map\" \
+ -DX_SERVER=\"$(bindir)/X\" \
-I $(top_srcdir)/src \
-I $(top_srcdir)/src/readahead \
-I $(top_srcdir)/src/login \
@@ -1988,6 +1989,20 @@ logind-install-data-hook:
INSTALL_DATA_HOOKS += \
logind-install-data-hook
+systemd_multi_seat_x_SOURCES = \
+ src/login/multi-seat-x.c
+
+systemd_multi_seat_x_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(UDEV_CFLAGS)
+
+systemd_multi_seat_x_LDADD = \
+ libsystemd-basic.la \
+ $(UDEV_LIBS)
+
+rootlibexec_PROGRAMS += \
+ systemd-multi-seat-x
+
systemd_uaccess_SOURCES = \
src/login/uaccess.c