summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2013-11-12 15:43:17 -0500
committerTom Gundersen <teg@jklm.no>2013-11-12 22:38:08 +0100
commit3c9317d2d93248f3f0b0feaaa113485aee415d8a (patch)
tree14d174df35b3f12b988a1a8275bcb0f4e723b684 /Makefile.am
parent735e5d83ee3391f8ab0e18218278302c2e87e5f3 (diff)
build-sys: Add --disable-networkd option
For GNOME (Continuous), we are unlikely to require or want systemd-networkd in the near term future; all of the tools and code are targeting NetworkManager. The long term story is still an open question of course, but for now, there's no reason for gnome-continuous to build or ship this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8710462aa..ce47171b7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3812,6 +3812,7 @@ EXTRA_DIST += \
endif
# ------------------------------------------------------------------------------
+if ENABLE_NETWORKD
rootlibexec_PROGRAMS += \
systemd-networkd
@@ -3863,6 +3864,7 @@ EXTRA_DIST += \
CLEANFILES += \
src/network/networkd-gperf.c
+endif
# ------------------------------------------------------------------------------
if ENABLE_LOGIND