summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDidier Roche <didrocks@ubuntu.com>2014-11-24 09:54:18 +0100
committerLennart Poettering <lennart@poettering.net>2014-12-03 03:41:19 +0100
commit3fb394369ccd6787f8f883e0f81dc7f35cb1ec51 (patch)
treebd937a34fa38a7299c8c79aec985386966921881 /Makefile.am
parent979ef53a268d6f54a309fc5c6015df5d4accbbd5 (diff)
machine-id-commit: Introduce machine-id-commit binary
This binary enables to commit transient machine-id on disk if it becomes writable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 46a838d4a..2efd0333f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -385,6 +385,7 @@ rootlibexec_PROGRAMS = \
systemd-remount-fs \
systemd-reply-password \
systemd-fsck \
+ systemd-machine-id-commit \
systemd-ac-power \
systemd-sysctl \
systemd-sleep \
@@ -2216,6 +2217,17 @@ systemd_fsck_LDADD = \
libsystemd-shared.la
# ------------------------------------------------------------------------------
+systemd_machine_id_commit_SOURCES = \
+ src/machine-id-commit/machine-id-commit.c \
+ src/core/machine-id-setup.c \
+ src/core/machine-id-setup.h
+
+systemd_machine_id_commit_LDADD = \
+ libsystemd-label.la \
+ libsystemd-internal.la \
+ libsystemd-shared.la
+
+# ------------------------------------------------------------------------------
systemd_ac_power_SOURCES = \
src/ac-power/ac-power.c