summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-05-17 03:13:58 +0200
committerLennart Poettering <lennart@poettering.net>2013-05-17 04:26:27 +0200
commit45fbe937d7ca8d0da9ea276d57bc70ebd41c285e (patch)
tree95b216605530430206c7d863bca4d1d610382d25 /Makefile.am
parentd5a2b9a6f455468a0f29483303657ab4fd7013d8 (diff)
bus: add minimal locking around the memfd cache
We want to allow clients to process an sd_bus_message on a different thread than it was received on. Since unreffing a bus message might readd some of its memfds to the memfd cache add some minimal locking around the cache.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 526598277..66f12e903 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1749,6 +1749,10 @@ libsystemd_bus_la_LIBADD = \
libsystemd-shared.la \
libsystemd-daemon.la
+libsystemd_bus_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -pthread
+
noinst_LTLIBRARIES += \
libsystemd-bus.la