summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTollef Fog Heen <tfheen@err.no>2010-05-10 01:17:49 +0200
committerTollef Fog Heen <tfheen@err.no>2010-05-10 01:17:49 +0200
commit462b33e96ad1732658b39895eea0b146e98bc3a5 (patch)
treeee487e5fef7994699425aba75c4f4bfb05994d7b /Makefile.am
parent75db651adba49238a02fe031842155d30e7a8219 (diff)
Distribute the necessary header files too
Add all header files that we need to EXTRA_DIST to ensure they are actually in the tarball.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7396dddd8..f475e9849 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -131,6 +131,16 @@ COMMON_SOURCES = \
fdset.c \
namespace.c
+EXTRA_DIST += \
+ ${COMMON_SOURCES:.c=.h} \
+ macro.h \
+ ioprio.h \
+ missing.h \
+ list.h \
+ securebits.h \
+ linux/auto_dev-ioctl.h \
+ initreq.h
+
systemd_SOURCES = \
$(COMMON_SOURCES) \
main.c