summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2015-02-17 18:01:10 +0100
committerKay Sievers <kay@vrfy.org>2015-02-17 18:01:33 +0100
commit484122c3458ae5ff5236dd4a6e6ddffcffa08336 (patch)
treebd64973f4dca02702ceb331d02dabf5f146bc068 /Makefile.am
parent90adaa25e894a580930ef2c3e65ab8db8295515a (diff)
build-sys: add missing HAVE_GNUEFI condition
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a17642f7..51c6d33af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2505,6 +2505,7 @@ dist_zshcompletion_DATA += \
shell-completion/zsh/_bootctl
# ------------------------------------------------------------------------------
+if HAVE_GNUEFI
efi_cppflags = \
$(EFI_CPPFLAGS) \
-I$(top_builddir) -include config.h \
@@ -2625,6 +2626,7 @@ test-efi-disk.img: $(sd_boot) $(stub) test/test-efi-create-disk.sh
test-efi: test-efi-disk.img
$(QEMU) -machine accel=kvm -m 1024 -bios $(QEMU_BIOS) -snapshot test-efi-disk.img
endif
+endif
# ------------------------------------------------------------------------------
if HAVE_BLKID