summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-31 14:11:23 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-02-06 09:13:12 -0500
commit4e829d218cb2ba7e50616945007081f4c7fe0e29 (patch)
treec7846ef0049f4aca3d7186b62a92ca869fee3428 /Makefile.am
parent757b23a6cd15f4b5fdcc3ea99754b7173aff0309 (diff)
localed: add LANGUAGE= fallback when LANG= is specified
For the entries listed in the first column of language-fallback-map, the entry from the second column will be used for LANGUAGE=, if LANGUAGE= is not explicitly specified. https://bugzilla.redhat.com/show_bug.cgi?id=624158
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 12116c500..d2899143b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -190,6 +190,7 @@ AM_CPPFLAGS = \
-DSYSTEM_SHUTDOWN_PATH=\"$(systemshutdowndir)\" \
-DSYSTEM_SLEEP_PATH=\"$(systemsleepdir)\" \
-DSYSTEMD_KBD_MODEL_MAP=\"$(pkgdatadir)/kbd-model-map\" \
+ -DSYSTEMD_LANGUAGE_FALLBACK_MAP=\"$(pkgdatadir)/language-fallback-map\" \
-DX_SERVER=\"$(bindir)/X\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \
-DPOLKIT_AGENT_BINARY_PATH=\"$(bindir)/pkttyagent\" \
@@ -4990,7 +4991,8 @@ BUSNAMES_TARGET_WANTS += \
org.freedesktop.locale1.busname
dist_pkgdata_DATA += \
- src/locale/kbd-model-map
+ src/locale/kbd-model-map \
+ src/locale/language-fallback-map
localectl_SOURCES = \
src/locale/localectl.c