summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorŁukasz Stelmach <l.stelmach@samsung.com>2014-11-28 15:59:59 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2014-11-30 23:50:19 -0500
commit5a16bc264c32237e38a844d55e7a1820a31b8440 (patch)
tree0f259cac8dcc873dff16ea25f8c6e9f7b7dc6889 /Makefile.am
parentf4e9cdbc6259237b2cb779a16e7c1aca0fd44e58 (diff)
build-sys: configure the list of system users, files and directories
Choose which system users defined in sysusers.d/systemd.conf and files or directories in tmpfiles.d/systemd.conf, should be provided depending on comile-time configuration.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cd81a7775..38d320fc3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5856,6 +5856,10 @@ src/%: src/%.m4
$(AM_V_at)$(MKDIR_P) $(dir $@)
$(AM_V_M4)$(M4) -P $(M4_DEFINES) < $< > $@
+sysusers.d/%: sysusers.d/%.m4
+ $(AM_V_at)$(MKDIR_P) $(dir $@)
+ $(AM_V_M4)$(M4) -P $(M4_DEFINES) < $< > $@
+
tmpfiles.d/%: tmpfiles.d/%.m4
$(AM_V_at)$(MKDIR_P) $(dir $@)
$(AM_V_M4)$(M4) -P $(M4_DEFINES) < $< > $@