summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-08-08 12:03:34 +0200
committerLennart Poettering <lennart@poettering.net>2012-08-08 12:03:34 +0200
commit5a45a93627609451784a04366cfa1150d32611d1 (patch)
treeb901ba044e5a8e274060f5ae7d85243a12a1eaa5 /Makefile.am
parentb2c9cbafb8b1a2742978e1faf37fbb3cf4fb5d44 (diff)
build-sys: enable a couple of security features
Most distributions enable these downstream anyway, but it probably makes sense to enable them unconditionally upstream too.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index b1a8cc199..696372246 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -148,10 +148,11 @@ AM_CPPFLAGS = \
-I $(top_builddir)/src/core \
-I $(top_srcdir)/src/core \
-I $(top_srcdir)/src/libudev \
- -I $(top_srcdir)/src/udev
+ -I $(top_srcdir)/src/udev \
+ $(OUR_CPPFLAGS)
-AM_CFLAGS = $(WARNINGFLAGS)
-AM_LDFLAGS = $(GCLDFLAGS)
+AM_CFLAGS = $(OUR_GFLAGS)
+AM_LDFLAGS = $(OUR_LDFLAGS)
# ------------------------------------------------------------------------------
if TARGET_GENTOO