summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2012-12-03 20:15:22 +0100
committerTom Gundersen <teg@jklm.no>2012-12-04 02:11:37 +0100
commit5fe25affc01fb003a3a66937458a25640a6075ce (patch)
tree9dcc8643473f2e4d43e2b79d9eece0c245ff45c2 /Makefile.am
parentd9847b32462d3943c9788e05454364f544617b9d (diff)
hwdb: add IAB to the OUI database
The individual address block is a poor man's organizationally unique identifier. Perhaps we should change the udev key from ID_OUI_FROM_DATABASE to something like ID_IEEE_VENDOR_FROM_DATABASE? Suggested-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b40a1c16a..bafd4734c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4145,7 +4145,8 @@ distclean-local: $(DISTCLEAN_LOCAL_HOOKS)
clean-local:
rm -rf $(abs_srcdir)/install-tree
- rm -f $(abs_srcdir)/hwdb/usb.ids $(abs_srcdir)/hwdb/pci.ids $(abs_srcdir)/hwdb/oui.txt
+ rm -f $(abs_srcdir)/hwdb/usb.ids $(abs_srcdir)/hwdb/pci.ids $(abs_srcdir)/hwdb/oui.txt \
+ $(abs_srcdir)/hwdb/iab.txt
DISTCHECK_CONFIGURE_FLAGS = \
--with-dbuspolicydir=$$dc_install_base/$(dbuspolicydir) \
@@ -4173,6 +4174,7 @@ hwdb-update:
wget -N http://www.linux-usb.org/usb.ids && \
wget -N http://pci-ids.ucw.cz/v2.2/pci.ids && \
wget -N http://standards.ieee.org/develop/regauth/oui/oui.txt && \
+ wget -N http://standards.ieee.org/develop/regauth/iab/iab.txt && \
./ids-update.pl )
upload: all distcheck