summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-20 09:20:35 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-02-28 20:04:17 -0500
commit603c0b7b14a6b59a87ede20b2fdb6765e773c0ed (patch)
tree82da52b91df3e23ce5b615d86624fa326e039302 /Makefile.am
parent2c07646764384545e5303222729d5ff93dec4347 (diff)
build-sys: make sphinx support uncoditional
It needs to be invoked explicitly, so there's no need to check explicitly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fc7e8c429..dfe70a570 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3453,13 +3453,12 @@ BUILT_SOURCES += \
src/python-systemd/id128-constants.h
endif
-if ENABLE_SPHINX
PAPER = $(shell cat /etc/papersize 2>/dev/null || echo a4)
SPHINXOPTS = -D latex_paper_size=$(PAPER)
sphinx-%:
+ $(AM_V_at)test -n "$(SPHINX_BUILD)" || { echo " *** sphinx-build is not available"; exit 1; }
$(AM_V_GEN)PYTHONPATH=$(DESTDIR)$(pyexecdir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) $(top_srcdir)/src/python-systemd/docs $(top_builddir)/man/python-systemd/
$(AM_V_at)echo Output has been generated in $(abs_top_builddir)/man/python-systemd/
-endif
# ------------------------------------------------------------------------------
SED_PROCESS = \