summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-14 04:22:29 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-14 04:22:29 +0200
commit64c1b5bf9c5777261bdf4058b6cd1cb5de193d5b (patch)
tree446315e98033857b03e2426f165741008ef50d0c /Makefile.am
parent173e382182d7f1ad2b132b6e923ef731d6affdf7 (diff)
install: create /cgroup/debug mount point on install
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 26a2c9585..8ad1969bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -252,6 +252,10 @@ CLEANFILES = \
systemd-logger.service
install-data-hook:
- $(MKDIR_P) $(DESTDIR)$(pkgsysconfdir)/system $(DESTDIR)$(pkgsysconfdir)/session $(DESTDIR)$(sysconfdir)/xdg/systemd
+ $(MKDIR_P) -m 0755 \
+ $(DESTDIR)$(pkgsysconfdir)/system \
+ $(DESTDIR)$(pkgsysconfdir)/session \
+ $(DESTDIR)$(sysconfdir)/xdg/systemd \
+ $(DESTDIR)/cgroup/debug
rm -f $(DESTDIR)$(sysconfdir)/xdg/systemd/session
ln -sf $(DESTDIR)$(pkgsysconfdir)/session $(DESTDIR)$(sysconfdir)/xdg/systemd/session