summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-27 21:22:26 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-01-27 21:48:12 -0500
commit78eb158a20e2bee772f6e49d8b432b98f68cbb55 (patch)
treec0fda585fc02935edbc385d6fd728fb9355280de /Makefile.am
parentb57b06258e0b1894edb6d1fc52a80b3c33164892 (diff)
build-sys: add check for --help width
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f42f13255..620b4d22f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6556,7 +6556,7 @@ endif
#
# Require python when making dist
#
-.PHONY: dist-check-python
+.PHONY: dist-check-python dist-check-compat-libs dist-check-help
dist-check-python:
if !HAVE_PYTHON
@echo "*** python and python-lxml module must be installed and enabled in order to make dist"
@@ -6569,6 +6569,14 @@ if !ENABLE_COMPAT_LIBS
@false
endif
+dist-check-help: $(rootbin_PROGRAMS) $(bin_PROGRAMS)
+ for i in $(abspath $^); do \
+ if $$i --help | grep -v 'default:' | grep -E -q '.{80}.' ; then \
+ echo "$(basename $$i) --help output is too wide:"; \
+ $$i --help | awk 'length > 80' | grep -E --color=yes '.{80}'; \
+ exit 1; \
+ fi; done
+
dist: dist-check-python dist-check-compat-libs
# check "broken" platforms limited toolchains for link breakage before we release