summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSusant Sahani <susant@redhat.com>2014-05-12 10:48:24 +0530
committerTom Gundersen <teg@jklm.no>2014-05-12 17:37:12 +0200
commit7951dea20911969287878e6897b3eca348721ade (patch)
tree420a101f2a4e3912b9d078bcf16bf06e8ff94742 /Makefile.am
parent1727a595225132eb73ec134b6979d9c713b42e8c (diff)
networkd: introduce ipip tunnel
This patch enables basic ipip tunnel support. It works with kernel module ipip example conf: file: ipip.netdev [NetDev] Name=ipip-tun Kind=ipip MTUBytes=1480 [Tunnel] Local=192.168.223.238 Remote=192.169.224.239 TTL=64 file: ipip.network [Match] Name=em1 [Network] Tunnel=ipip-tun [tomegun: - drop unused variable - take ref when enslaving]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 637f5e15c..c54d35760 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4171,7 +4171,8 @@ systemd_networkd_SOURCES = \
src/network/networkd.c
systemd_networkd_LDADD = \
- libsystemd-networkd-core.la
+ libsystemd-networkd-core.la \
+ -lkmod
noinst_LTLIBRARIES += \
libsystemd-networkd-core.la
@@ -4181,6 +4182,7 @@ libsystemd_networkd_core_la_SOURCES = \
src/network/networkd.h \
src/network/networkd-link.c \
src/network/networkd-netdev.c \
+ src/network/networkd-tunnel.c \
src/network/networkd-network.c \
src/network/networkd-address.c \
src/network/networkd-route.c \
@@ -4217,13 +4219,15 @@ systemd_networkd_wait_online_LDADD = \
libsystemd-network.la \
libudev-internal.la \
libsystemd-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ libsystemd-network.la
test_network_SOURCES = \
src/network/test-network.c
test_network_LDADD = \
- libsystemd-networkd-core.la
+ libsystemd-networkd-core.la \
+ -lkmod
tests += \
test-network