summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarius Vollmer <marius.vollmer@redhat.com>2013-06-07 00:50:21 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-06-10 10:10:07 -0400
commit7a050b54b7c78717d5efb2e380623ccad2a70148 (patch)
tree77e4ee3337a5121a5bc9df94589ba19221ee99bd /Makefile.am
parentbc3029268ca0077f2e176724d7d124cec4265575 (diff)
tests: add testcase for skipping-entries-on-direction-change-bug
This test case failed until a3e6f050de8. Taken from https://bugs.freedesktop.org/show_bug.cgi?id=65255.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 70da1e4a2..28ae7edea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2781,6 +2781,14 @@ test_journal_verify_LDADD = \
libsystemd-journal-internal.la \
libsystemd-id128-internal.la
+test_journal_interleaving_SOURCES = \
+ src/journal/test-journal-interleaving.c
+
+test_journal_interleaving_LDADD = \
+ libsystemd-shared.la \
+ libsystemd-journal-internal.la \
+ libsystemd-id128-internal.la
+
test_mmap_cache_SOURCES = \
src/journal/test-mmap-cache.c
@@ -2956,6 +2964,7 @@ tests += \
test-journal-match \
test-journal-stream \
test-journal-verify \
+ test-journal-interleaving \
test-mmap-cache \
test-catalog