summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2012-12-23 10:18:21 -0500
committerKay Sievers <kay@vrfy.org>2012-12-23 16:25:24 +0100
commit81dc4bde12acd0a59ad96a505dbb109a9e4f320e (patch)
tree4150b39df9dd589e77d2b6db4f8956e1e979e8b3 /Makefile.am
parentc96cb78f489391a1ae079c70cc76b3e356bf03b0 (diff)
build-sys: Make libsystemd-shared link to libsystemd-daemon
Commit f934051c4d17d167bd8e46dd3c70a745e26fd2eb broke the build because it made libsystemd-shared call sd_listen_fds() which is defined in libsystemd-daemon. This is a bit of a contortion because libsystemd-shared.la is a noinst_LTLIBRARY, but libtool should do the right thing here and emit DT_NEEDED on libsystemd-daemon.so for things that consume libsystemd-shared.la.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 165b85dea..163a180dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -849,6 +849,8 @@ libsystemd_shared_la_SOURCES = \
src/shared/calendarspec.c \
src/shared/calendarspec.h
+libsystemd_shared_la_LIBADD = libsystemd-daemon.la
+
#-------------------------------------------------------------------------------
noinst_LTLIBRARIES += \
libsystemd-dbus.la