summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAuke Kok <auke-jan.h.kok@intel.com>2012-10-17 16:01:12 -0700
committerKay Sievers <kay@vrfy.org>2013-01-07 23:48:43 +0100
commit83fdc450aa8f79941bec84488ffd5bf8eadab18e (patch)
tree44e8f381df2d891684ab7b45306314bd762fb783 /Makefile.am
parentd0100018c2b03938a2e0821383f578a2372df517 (diff)
bootchart: merge bootchart
Bootchart is renamed to 'systemd-bootchart' and installed as /usr/lib/systemd/systemd-bootchart. The configuration file will reside in /etc/systemd/bootchart.conf.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c1bb5a7bf..15bc4c6c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3020,6 +3020,22 @@ EXTRA_DIST += \
units/systemd-readahead-done.service.in
# ------------------------------------------------------------------------------
+if ENABLE_BOOTCHART
+systemd_bootchart_SOURCES = \
+ src/bootchart/bootchart.c \
+ src/bootchart/bootchart.h \
+ src/bootchart/log.c \
+ src/bootchart/svg.c
+
+MANPAGES += \
+ man/systemd-bootchart.1
+ man/bootchart.conf.5
+
+rootlibexec_PROGRAMS += \
+ systemd-bootchart
+endif
+
+# ------------------------------------------------------------------------------
if ENABLE_QUOTACHECK
rootlibexec_PROGRAMS += \
systemd-quotacheck