summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Hoyer <harald@redhat.com>2015-02-18 14:45:12 +0100
committerTom Gundersen <teg@jklm.no>2015-02-18 15:23:23 +0100
commit8d4efa540a88b19a475452d8ccc3c9824849fa86 (patch)
tree735843ccfe71614b77114aec5f0bfb2a9443c4d2 /Makefile.am
parentf3ec7b3b7ff0fcd0b199e896df21aef12cdb5e67 (diff)
Makefile.am:efi_cflags compile with gcc v5
Set -std=gnu90 to let efibind.h define the standard types. [tomegun: retyped the patch as the originl would not apply]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 51c6d33af..a5e07cfa6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2533,7 +2533,8 @@ if ARCH_X86_64
efi_cflags += \
-mno-red-zone \
-DEFI_FUNCTION_WRAPPER \
- -DGNU_EFI_USE_MS_ABI
+ -DGNU_EFI_USE_MS_ABI \
+ -std=gnu90
endif
efi_ldflags = \