summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-09-13 04:01:18 +0200
committerLennart Poettering <lennart@poettering.net>2012-09-13 04:01:18 +0200
commit8d7e170a5230753d8406276f8b5598e5bb6766e6 (patch)
tree0e3ddb182b1bc5468657fa5d836733029783801d /Makefile.am
parent3612fbc1e4ae57af0783cc82a56917bcd29a0431 (diff)
python: integrate David Strauss' python-systemd package
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 730db1d5a..be97193b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3408,6 +3408,37 @@ EXTRA_DIST += \
# ------------------------------------------------------------------------------
+if HAVE_PYTHON_DEVEL
+
+pkgpyexec_LTLIBRARIES = \
+ _journal.la
+
+_journal_la_SOURCES = \
+ src/python-systemd/_journal.c
+
+_journal_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -fvisibility=default \
+ $(PYTHON_CFLAGS)
+
+_journal_la_LDFLAGS = \
+ $(AM_LDFLAGS) \
+ -shared \
+ -module \
+ -avoid-version
+
+_journal_la_LIBADD = \
+ $(PYTHON_LIBS) \
+ libsystemd-journal.la
+
+dist_pkgpyexec_PYTHON = \
+ src/python-systemd/journal.py \
+ src/python-systemd/__init__.py
+
+endif
+
+# ------------------------------------------------------------------------------
+
SED_PROCESS = \
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
$(SED) -e 's,@rootlibexecdir\@,$(rootlibexecdir),g' \