summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Reisner <dreisner@archlinux.org>2012-04-04 00:22:21 -0400
committerKay Sievers <kay.sievers@vrfy.org>2012-04-04 06:46:35 +0200
commit9cf2578683de834026f501c24a0f5d3d0991d0a6 (patch)
tree754bd599f15dee874b2c50f33c68df386e569e6e /Makefile.am
parent9b1a953e08917030489cd9adb2a17dfd407ce14b (diff)
units/: use @SYSTEMCTL@ instead of hardcoded paths
Especially in the case of --enable-split-usr, several units will point to the wrong location for systemctl. Use @SYSTEMCTL@ which will always contain the proper path.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b04142ea..3cb50d854 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -338,6 +338,7 @@ nodist_systemunit_DATA = \
units/systemd-ask-password-console.service \
units/systemd-sysctl.service \
units/halt.service \
+ units/emergency.service \
units/poweroff.service \
units/reboot.service \
units/kexec.service \
@@ -359,8 +360,8 @@ nodist_userunit_DATA = \
EXTRA_DIST += \
units/getty@.service.m4 \
units/serial-getty@.service.m4 \
- units/console-shell.service.m4 \
- units/rescue.service.m4 \
+ units/console-shell.service.m4.in \
+ units/rescue.service.m4.in \
units/systemd-initctl.service.in \
units/systemd-shutdownd.service.in \
units/systemd-modules-load.service.in \
@@ -372,6 +373,7 @@ EXTRA_DIST += \
units/systemd-ask-password-wall.service.in \
units/systemd-ask-password-console.service.in \
units/systemd-sysctl.service.in \
+ units/emergency.service.in \
units/halt.service.in \
units/poweroff.service.in \
units/reboot.service.in \