summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2014-04-12 22:35:50 -0700
committerKay Sievers <kay@vrfy.org>2014-04-13 17:12:14 -0700
commit9ea28c55a2488e6cd4a44ac5786f12b71ad5bc9f (patch)
tree3aeccb80e1b72169b8bc4836b5a6d1a76130ebe3 /Makefile.am
parenta163b64c4b08e8a4ad39a9a295acf3d1634024a3 (diff)
udev: remove seqnum API and all assumptions about seqnums
The way the kernel namespaces have been implemented breaks assumptions udev made regarding uevent sequence numbers. Creating devices in a namespace "steals" uevents and its sequence numbers from the host. It confuses the "udevadmin settle" logic, which might block until util a timeout is reached, even when no uevent is pending. Remove any assumptions about sequence numbers and deprecate libudev's API exposing these numbers; none of that can reliably be used anymore when namespaces are involved.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5d846052d..0ad1729c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2587,8 +2587,7 @@ noinst_LTLIBRARIES += \
libudev_internal_la_SOURCES =\
$(libudev_la_SOURCES) \
- src/libudev/libudev-device-private.c \
- src/libudev/libudev-queue-private.c
+ src/libudev/libudev-device-private.c
libudev_internal_la_CFLAGS = \
$(AM_CFLAGS) \
@@ -5169,6 +5168,9 @@ test_libsystemd_sym_LDADD = \
test_libudev_sym_SOURCES = \
test-libudev-sym.c
+test_libudev_sym_CFLAGS = \
+ $(AM_CFLAGS) \
+ -Wno-deprecated-declarations
test_libudev_sym_LDADD = \
libudev.la