summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-01-04 23:19:02 +0100
committerLennart Poettering <lennart@poettering.net>2013-01-04 23:26:21 +0100
commita382332eed10d3348231803c47a4c599d24c5e3a (patch)
tree9629fce80ac4b430961ea5f76a3c9a469b4863fc /Makefile.am
parent425c608d5319cae993d786a3915064bbb580c17b (diff)
build-sys: make path of loadkeys/setfont configurable in configure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 0 insertions, 41 deletions
diff --git a/Makefile.am b/Makefile.am
index 9132ccdfc..b11dfb95e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -168,47 +168,6 @@ AM_CFLAGS = $(OUR_CFLAGS)
AM_LDFLAGS = $(OUR_LDFLAGS)
# ------------------------------------------------------------------------------
-if TARGET_GENTOO
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\"
-else
-if TARGET_ARCH
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\"
-else
-if TARGET_FRUGALWARE
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\"
-else
-if TARGET_MANDRIVA
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\"
-else
-if TARGET_ANGSTROM
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/usr/bin/loadkeys\" \
- -DKBD_SETFONT=\"/usr/bin/setfont\"
-else
-if TARGET_MAGEIA
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\"
-else
-AM_CPPFLAGS += \
- -DKBD_LOADKEYS=\"/bin/loadkeys\" \
- -DKBD_SETFONT=\"/bin/setfont\"
-endif
-endif
-endif
-endif
-endif
-endif
-
-# ------------------------------------------------------------------------------
rootbin_PROGRAMS = \
systemctl \
systemd-notify \