summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-09 18:10:44 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-09 18:13:33 -0400
commita7739f8f973b1a57ee0f8a9404a7c8ed375f2197 (patch)
treef335a94a7e96418950cd174f14efae2150914fa2 /Makefile.am
parent7ecec4705c0cacb1446af0eb7a4aee66c00d058f (diff)
build-sys: add convinience 'make python-shell'
This will launch $(PYTHON) with $LD_LIBRARY_PATH and $PYTHONPATH as ./configure-d and DESTDIR-ed. Use as: make install DESTDIR=/var/tmp/inst python-shell
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a196a65e..0ac99a688 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3826,6 +3826,10 @@ sphinx-%:
$(AM_V_GEN)PYTHONPATH=$(DESTDIR)$(pyexecdir) LD_LIBRARY_PATH=$(DESTDIR)$(libdir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) $(top_srcdir)/src/python-systemd/docs $(top_builddir)/docs/html/python-systemd/
$(AM_V_at)echo Output has been generated in $(abs_top_builddir)/docs/html/python-systemd/
+python-shell:
+ $(AM_V_at)echo "Starting python with $(DESTDIR)$(pyexecdir)"
+ $(AM_V_at)PYTHONPATH=$(DESTDIR)$(pyexecdir) LD_LIBRARY_PATH=$(DESTDIR)$(libdir) $(PYTHON)
+
destdir-sphinx: all
dir="$$(mktemp -d /tmp/systemd-install.XXXXXX)" && \
$(MAKE) DESTDIR="$$dir" install && \