summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-04-05 07:25:10 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-04-05 11:43:46 -0400
commitac2b34e155da16cde2cb9a0b25d8c3bf9dcaa018 (patch)
treece2f9de108579500dcde85a7368606497b2bf1c9 /Makefile.am
parentb7f247e0befb6595049bc2410fe370e21d1f7444 (diff)
build-sys: use LN_S in Makefile.am
For consistency only. We're Linux only, so it really makes no difference. https://bugs.freedesktop.org/show_bug.cgi?id=63036
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 59a3886f1..91e96930e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -222,7 +222,7 @@ define add-wants
$(MKDIR_P) -m 0755 $$dir && \
cd $$dir && \
rm -f $$what && \
- for i in $$what; do ln -s ../$$i . || exit $$? ; done )
+ for i in $$what; do $(LN_S) ../$$i . || exit $$? ; done )
endef
install-directories-hook:
@@ -240,7 +240,7 @@ define install-aliases
$(MKDIR_P) /$(DESTDIR)$$dir && \
while [ -n "$$1" ]; do \
rm -f $(DESTDIR)$$dir/$$2 && \
- ln -s $$1 $(DESTDIR)$$dir/$$2 && \
+ $(LN_S) $$1 $(DESTDIR)$$dir/$$2 && \
shift 2 || exit $$?; \
done
endef