summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2013-01-04 21:48:47 +0100
committerLennart Poettering <lennart@poettering.net>2013-01-04 23:26:20 +0100
commitb1c4ca25bf58e1925012d1dcdd83d61cecbf87fb (patch)
tree564526d2532f87ea2b90d974b87e0b5c4ce6619d /Makefile.am
parent46a2911bf2780f616396df5671dd901cc7cb54fd (diff)
build-sys: make rc-local support part of SYSV compat
This also drops automatic selection of the rc local scripts based on the local distro. Distributions now should specify the paths of the rc-local and halt-local scripts on the configure command line.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 9 insertions, 32 deletions
diff --git a/Makefile.am b/Makefile.am
index 94ae549b8..9132ccdfc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -406,34 +406,15 @@ EXTRA_DIST += \
units/systemd-modules-load.service.in
endif
-if TARGET_FEDORA
-dist_systemunit_DATA += \
- units/fedora/rc-local.service \
- units/fedora/halt-local.service
-systemgenerator_PROGRAMS += \
- systemd-rc-local-generator
-endif
-
-if TARGET_MANDRIVA
-dist_systemunit_DATA += \
- units/fedora/rc-local.service \
- units/fedora/halt-local.service
-systemgenerator_PROGRAMS += \
- systemd-rc-local-generator
-endif
+if HAVE_SYSV_COMPAT
+nodist_systemunit_DATA += \
+ units/rc-local.service \
+ units/halt-local.service
-if TARGET_SUSE
-dist_systemunit_DATA += \
- units/suse/rc-local.service \
- units/suse/halt-local.service
-systemgenerator_PROGRAMS += \
- systemd-rc-local-generator
-endif
+EXTRA_DIST += \
+ units/rc-local.service.in \
+ units/halt-local.service.in
-if TARGET_MAGEIA
-dist_systemunit_DATA += \
- units/fedora/rc-local.service \
- units/fedora/halt-local.service
systemgenerator_PROGRAMS += \
systemd-rc-local-generator
endif
@@ -3856,6 +3837,8 @@ SED_PROCESS = \
-e 's,@QUOTACHECK\@,$(QUOTACHECK),g' \
-e 's,@SYSTEM_SYSVINIT_PATH\@,$(sysvinitdir),g' \
-e 's,@VARLOGDIR\@,$(varlogdir),g' \
+ -e 's,@RC_LOCAL_SCRIPT_PATH_START\@,$(RC_LOCAL_SCRIPT_PATH_START),g' \
+ -e 's,@RC_LOCAL_SCRIPT_PATH_STOP\@,$(RC_LOCAL_SCRIPT_PATH_STOP),g' \
< $< > $@
units/%: units/%.in Makefile
@@ -4133,12 +4116,6 @@ if TARGET_MANDRIVA
$(LN_S) rescue.service single.service )
endif
-if TARGET_SUSE
- ( cd $(DESTDIR)$(systemunitdir) && \
- rm -f local.service && \
- $(LN_S) rc-local.service local.service )
-endif
-
if TARGET_MAGEIA
( cd $(DESTDIR)$(systemunitdir) && \
rm -f display-manager.service )