summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPatrik Flykt <patrik.flykt@linux.intel.com>2013-12-09 23:43:10 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-12-12 11:43:33 -0500
commitb5d01d174c5cb3d2ae49875d3bc1f233c5412120 (patch)
treecfa2d8a0d69a18485a92718250e164ef7e8eb529 /Makefile.am
parentbe391925d52bde04ea9b14f868a401d545c67af9 (diff)
build: Add initial build support
The client test program is the only one to be built so far.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 25bbcab88..9b5c49624 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3847,6 +3847,19 @@ lib_LTLIBRARIES += \
endif
# ------------------------------------------------------------------------------
+test_dhcp_client_SOURCES = \
+ src/libsystemd-dhcp/protocol.h \
+ src/systemd/sd-dhcp-client.h \
+ src/libsystemd-dhcp/dhcp-client.c \
+ src/libsystemd-dhcp/test-dhcp-client.c
+
+test_dhcp_client_LDADD = \
+ libsystemd-shared.la
+
+tests += \
+ test-dhcp-client
+
+# ------------------------------------------------------------------------------
if ENABLE_MACHINED
systemd_machined_SOURCES = \
src/machine/machined.c \