summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-01 22:30:54 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-05-02 22:55:38 -0400
commitb5fafdf63f72b07ff646a898ef94a81643b8d1a7 (patch)
tree1f67cac69e13332562107f82eafaadab08176d41 /Makefile.am
parent11f22867f9cdbfc6656905861090cded91a41bd7 (diff)
build-sys: "link" python _reader and pam_systemd against libsd-daemon-internal
The same old story as d3b9e0ff: those two use libsystemd-shared, and in turn, some functions in libsystemd-shared use libsystemd-daemon. The fact that *those* functions are used neither by the python modules in question nor pam_systemd isn't always enough. Currently, I'm seeing linking failures with -flto. The result of adding libsystemd-daemon-internal to the list of linked libraries should be harmless, with no change in size or final link requirements.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d50ab3d70..4040a8529 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3597,6 +3597,7 @@ pam_systemd_la_LIBADD = \
libsystemd-audit.la \
libsystemd-dbus.la \
libsystemd-shared.la \
+ libsystemd-daemon-internal.la \
$(PAM_LIBS)
pamlib_LTLIBRARIES = \
@@ -3776,7 +3777,8 @@ _reader_la_LIBADD = \
$(PYTHON_LIBS) \
libsystemd-journal.la \
libsystemd-id128.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ libsystemd-daemon-internal.la
dist_pkgpyexec_PYTHON = \
src/python-systemd/journal.py \