summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2012-04-10 19:23:08 +0200
committerKay Sievers <kay@vrfy.org>2012-04-10 19:23:08 +0200
commitb6358b8d762253a1f9ebd82135ff1053dc796b88 (patch)
treec39917eab6659091d8293585d717a577f4abaacd /Makefile.am
parent0d0a5ab46a3dd2eb22fba59fbed95224acd42b80 (diff)
use libsystemd-daemon.la instead of source file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 1518ba9c8..1172125d9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -738,7 +738,6 @@ libsystemd_core_la_SOURCES = \
src/cgroup-attr.h \
src/watchdog.c \
src/watchdog.h \
- src/sd-daemon.c \
src/macro.h \
src/def.h \
src/ioprio.h \
@@ -799,6 +798,7 @@ systemd_CFLAGS = \
systemd_LDADD = \
libsystemd-core.la \
+ libsystemd-daemon.la \
libsystemd-id128.la
# ------------------------------------------------------------------------------
@@ -810,7 +810,8 @@ test_engine_CFLAGS = \
$(DBUS_CFLAGS)
test_engine_LDADD = \
- libsystemd-core.la
+ libsystemd-core.la \
+ libsystemd-daemon.la
test_job_type_SOURCES = \
src/test-job-type.c