summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRonny Chevalier <chevalier.ronny@gmail.com>2014-11-05 21:27:01 +0100
committerRonny Chevalier <chevalier.ronny@gmail.com>2014-11-08 22:45:56 +0100
commitbc9992978cd1456b5bb79e72e8cf7a2331d3a7c6 (patch)
tree5b424971ef9c92663c8fdc6da40a4df28b923f9e /Makefile.am
parented7fb9cb235d2aedb755dcb8a5a5d9cdffba1519 (diff)
tests: add test-path
It tests all available directives of Path units: - PathChanged - PathModified - PathExists - PathExisysGlob - DirectoryNotEmpty - MakeDirectory - DirectoryMode - Unit
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 461ffa944..698a7b0f3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1321,6 +1321,7 @@ tests += \
test-env-replace \
test-strbuf \
test-strv \
+ test-path \
test-path-util \
test-strxcpyx \
test-unit-name \
@@ -1809,6 +1810,15 @@ test_path_util_SOURCES = \
test_path_util_LDADD = \
libsystemd-shared.la
+test_path_SOURCES = \
+ src/test/test-path.c
+
+test_path_CFLAGS = \
+ $(AM_CFLAGS)
+
+test_path_LDADD = \
+ libsystemd-core.la
+
test_strxcpyx_SOURCES = \
src/test/test-strxcpyx.c