summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2017-02-16 06:16:10 +0100
committerSven Eden <yamakuzure@gmx.net>2017-03-14 10:23:13 +0100
commitc190efa0e56ab46fd484e489f31a7622bf041de6 (patch)
tree197a7c434e620d519439b0345bc9ce526985c729 /Makefile.am
parent99015227d48e9e04fe72ecf1f0a09a7c79ac575e (diff)
Detect running cgroup controller.
elogind has to run on any system, no matter which init system is in control of the cgroups. So instead of hardcoding "name=foo", configure now greps 1: in /proc/self/cgroup - which is hopefully the right choice. (Well, to be honest, if it isn't, something is really wrong with the running system...)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fe421287a..0d2f98657 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,7 @@ zshcompletiondir=@zshcompletiondir@
systemsleepdir=$(pkglibexecdir)/sleep.d
systemshutdowndir=$(pkglibexecdir)/shutdown.d
+CGROUP_CONTROLLER=@cgroup_controller@
PKTTYAGENT=$(bindir)/pkttyagent
# Our own, non-special dirs
@@ -68,9 +69,11 @@ factory_pamdir = $(datadir)/factory/etc/pam.d
# And these are the special ones for /
rootprefix=@rootprefix@
+rootlibdir=@rootlibdir@
rootbindir=$(rootprefix)/bin
rootlibexecdir=$(rootprefix)/lib/elogind
+
EXTRA_DIST =
BUILT_SOURCES =
INSTALL_EXEC_HOOKS =
@@ -119,6 +122,7 @@ CLEANFILES = $(BUILT_SOURCES) \
AM_CPPFLAGS = \
-include $(top_builddir)/config.h \
-DPKGSYSCONFDIR=\"$(pkgsysconfdir)\" \
+ -DELOGIND_CGROUP_CONTROLLER=\"$(CGROUP_CONTROLLER)\" \
-DELOGIND_CGROUP_AGENT_PATH=\"$(rootlibexecdir)/elogind-cgroups-agent\" \
-DROOTPREFIX=\"$(rootprefix)\" \
-DUDEVLIBEXECDIR=\"$(udevlibexecdir)\" \