summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-02-24 17:40:36 +0100
committerTom Gundersen <teg@jklm.no>2013-03-01 22:52:36 +0100
commitcf843477946451fabf9b5d17eec8ec81515057b6 (patch)
treea95ad3843fc36ce2707e6f9e2f5e0af7d07f4660 /Makefile.am
parent3d22d1ab57bf44c92e4d9ca95d9728105dd3fb0d (diff)
initrd: add unit files needed for basic systemd-in-initrd support
This will: * mount all configured filesystems (typically the rootfs on /sysroot) * reload the configuration to pick up anything from the mounted fs (typically /sysroot/etc/fstab) * mount any newly configured filesystems (typically /usr on /sysroot/usr, if applicable) * shut-down and clean-up any daemons running in the initramfs (typically udevd) * switch-root to /sysroot and start the real init For an example of what files should be included in an initramfs based on this see <https://mailman.archlinux.org/pipermail/arch-projects/2013-February/003628.html>. Cc: Harald Hoyer <harald.hoyer@gmail.com> Cc: Dave Reisner <d@falconindy.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 790e5014b..b69794994 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -379,7 +379,12 @@ dist_systemunit_DATA = \
units/systemd-ask-password-console.path \
units/systemd-udevd-control.socket \
units/systemd-udevd-kernel.socket \
- units/system-update.target
+ units/system-update.target \
+ units/initrd-parse-etc.service \
+ units/initrd-cleanup.service \
+ units/initrd-switch-root.target \
+ units/initrd-udevadm-cleanup-db.service \
+ units/initrd-switch-root.service
nodist_systemunit_DATA = \
units/getty@.service \