summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2014-11-24 15:12:42 +0100
committerDavid Herrmann <dh.herrmann@gmail.com>2014-11-24 15:16:33 +0100
commitd4f5a1f47dbd04f26f2ddf951c97c4cb0ebbbe62 (patch)
tree54e891570c54a505a6babdefc95169d1efb1aaa2 /Makefile.am
parent8a52210c9392887a31fdb2845f65b4c5869e8e66 (diff)
localed: validate xkb keymaps
Introduce a new optional dependency on libxkbcommon for systemd-localed. Whenever the x11 keymap settings are changed, use libxkbcommon to compile the keymap. If the compilation fails, print a warning so users will get notified. On compilation failure, we still update the keymap settings for now. This patch just introduces the xkbcommon infrastructure to have keymap validation in place. We can later decide if/how we want to enforce this.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f9f3fab3..1674f6195 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4626,7 +4626,12 @@ systemd_localed_SOURCES = \
systemd_localed_LDADD = \
libsystemd-label.la \
libsystemd-internal.la \
- libsystemd-shared.la
+ libsystemd-shared.la \
+ $(XKBCOMMON_LIBS)
+
+systemd_localed_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(XKBCOMMON_CFLAGS)
nodist_systemunit_DATA += \
units/systemd-localed.service