summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2013-01-05 18:37:52 +0100
committerTom Gundersen <teg@jklm.no>2013-01-07 15:15:57 +0100
commitd562955eac58d3a5089e0f344ea586412a134451 (patch)
tree4fca28daee0e2216e50f0d4fa48483f6df0a99d8 /Makefile.am
parentcbc06dcd8f74e9e757c55884a4acf49784fc3444 (diff)
nss-myhostname: integrate into systemd buildsystem
Note that there are still some rome for cleanups. In particular, the .la files are now installed, which we probably don't want; and some of the macros in Makefile.am are likely redundan.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 9920bc13f..91bc49dc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3549,6 +3549,27 @@ pamlib_LTLIBRARIES = \
pam_systemd.la
endif
+if HAVE_MYHOSTNAME
+libnss_myhostname_la_SOURCES = \
+ src/nss-myhostname/nss-myhostname.c \
+ src/nss-myhostname/ifconf.h \
+ src/nss-myhostname/netlink.c
+
+libnss_myhostname_la_CFLAGS = \
+ $(AM_CFLAGS)
+
+libnss_myhostname_la_LDFLAGS = \
+ $(AM_LDFLAGS) \
+ -module \
+ -export-dynamic \
+ -avoid-version \
+ -shared \
+ -shrext .so.2
+
+lib_LTLIBRARIES += \
+ libnss_myhostname.la
+endif
+
# move lib from $(libdir) to $(rootlibdir) and update devel link, if needed
libsystemd-login-install-hook:
libname=libsystemd-login.so && $(move-to-rootlibdir)