summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBill Nottingham <notting@redhat.com>2011-09-13 11:01:56 -0400
committerLennart Poettering <lennart@poettering.net>2011-09-20 03:35:09 +0200
commitd6bca18e28268485619127024fd944b8497798a7 (patch)
tree9384869240a83b475f3aa78844ee89cd95f4fa0a /Makefile.am
parent67d36a7a2039f1ff7d2d922d4a7c04ea30adc48f (diff)
units: Add support for automounting configfs, ala debugfs, etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e1d118688..60fb3ff72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -361,6 +361,8 @@ dist_systemunit_DATA = \
units/dev-hugepages.mount \
units/dev-mqueue.automount \
units/dev-mqueue.mount \
+ units/sys-kernel-config.automount \
+ units/sys-kernel-config.mount \
units/sys-kernel-debug.automount \
units/sys-kernel-debug.mount \
units/sys-kernel-security.automount \
@@ -1840,6 +1842,7 @@ endif
( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \
rm -f dev-hugepages.automount \
dev-mqueue.automount \
+ sys-kernel-config.automount \
sys-kernel-debug.automount \
sys-kernel-security.automount \
systemd-vconsole-setup.service \
@@ -1852,6 +1855,7 @@ endif
cryptsetup.target && \
$(LN_S) ../dev-hugepages.automount dev-hugepages.automount && \
$(LN_S) ../dev-mqueue.automount dev-mqueue.automount && \
+ $(LN_S) ../sys-kernel-config.automount sys-kernel-config.automount && \
$(LN_S) ../sys-kernel-debug.automount sys-kernel-debug.automount && \
$(LN_S) ../sys-kernel-security.automount sys-kernel-security.automount && \
$(LN_S) ../systemd-vconsole-setup.service systemd-vconsole-setup.service && \