summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2014-03-26 19:22:17 +0100
committerKay Sievers <kay@vrfy.org>2014-03-26 19:22:17 +0100
commite57e4e2be345f346bb49547ecad71dc000c406b2 (patch)
tree74ab06b96dc3656c5ad645a8ad1359cae1d7b22f /Makefile.am
parentbc61d6ac014a25e50cd0bc32fbd50cdb534be1c6 (diff)
build-sys: update "linkcheck"
<kay> ssuominen: and drop --no-as-needed from the linkcheck? <kay> ssuominen: i expect it all triggers without the gc-sections thing alone <ssuominen> if the intention is to make it strict as possible, to catch undefined references caused by missing -lfoo in linker line, then LDFLAGS="-Wl,-fuse-ld=gold -Wl,--as-needed -Wl,--no-gc-sections"
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ea5ede06f..88371a2df 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5038,7 +5038,7 @@ endif
# check "broken" platforms limited toolchains for link breakage before we release
.PHONY: linkcheck
linkcheck:
- $(MAKE) CFLAGS='-fno-lto' LDFLAGS='-Wl,--no-as-needed -Wl,--no-gc-sections' distcheck
+ $(MAKE) CFLAGS='-fno-lto' LDFLAGS='-Wl,-fuse-ld=gold -Wl,--as-needed -Wl,--no-gc-sections' distcheck
.PHONY: hwdb-update
hwdb-update: