summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2010-05-17 23:29:24 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-17 23:29:24 +0200
commite82e442bfa66eb982b1694250bdafdbd0de54032 (patch)
tree659fc51fcc591e9a631b2f82199dcc074c500f9c /Makefile.am
parentc3bd732210fb2f53bbea2ffc55d16a35e098ff94 (diff)
build-sys: don't fail if we cannot create /cgroup/debug
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 83740d73d..f67f22d64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -405,8 +405,8 @@ install-data-hook:
$(DESTDIR)$(pkgsysconfdir)/system/multi-user.target.wants \
$(DESTDIR)$(pkgsysconfdir)/system/graphical.target.wants \
$(DESTDIR)$(pkgsysconfdir)/session \
- $(DESTDIR)$(sysconfdir)/xdg/systemd \
- $(DESTDIR)/cgroup/debug
+ $(DESTDIR)$(sysconfdir)/xdg/systemd
+ $(MKDIR_P) -m 0755 $(DESTDIR)/cgroup/debug || echo "Don't forget to create /cgroup/debug! Couldn't create it for you, continuing anyway."
( cd $(DESTDIR)$(sysconfdir)/xdg/systemd/ && \
rm -f session && \
$(LN_S) $(pkgsysconfdir)/session session )