summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2012-12-23 11:23:59 +0100
committerLennart Poettering <lennart@poettering.net>2012-12-23 11:28:14 +0100
commite8bc0ea2b100158bf35c635039226235aa879068 (patch)
tree112767f16aada7f070cbbba4cf9b33ec69941284 /Makefile.am
parent2d0b0528ace89d378051c280bf3be367b2a7d2de (diff)
journalctl: strip TABs and ANSI color sequences from log messages when displaying them
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8021c9db2..65055b3fb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1232,7 +1232,8 @@ noinst_PROGRAMS += \
test-sleep \
test-replace-var \
test-sched-prio \
- test-calendarspec
+ test-calendarspec \
+ test-strip-tab-ansi
TESTS += \
test-job-type \
@@ -1244,7 +1245,8 @@ TESTS += \
test-sleep \
test-replace-var \
test-sched-prio \
- test-calendarspec
+ test-calendarspec \
+ test-strip-tab-ansi
EXTRA_DIST += \
test/sched_idle_bad.service \
@@ -1341,6 +1343,12 @@ test_calendarspec_SOURCES = \
test_calendarspec_LDADD = \
libsystemd-shared.la
+test_strip_tab_ansi_SOURCES = \
+ src/test/test-strip-tab-ansi.c
+
+test_strip_tab_ansi_LDADD = \
+ libsystemd-shared.la
+
test_daemon_SOURCES = \
src/test/test-daemon.c