summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-07 14:42:27 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2013-03-07 15:35:49 -0500
commite91fb201c7114f971b645c1f862e0ba890093704 (patch)
tree63b099454cf50c829b8a55ff8854b005ae21bbe6 /Makefile.am
parenta4c41bf3fa905c38e6e4d159c13eed890d53838b (diff)
build-sys: move sphinx output to docs/python-systemd
And on fd.o it goes into a dir parallel to man/.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f6493773..c1c8cdbad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3513,8 +3513,8 @@ PAPER = $(shell cat /etc/papersize 2>/dev/null || echo a4)
SPHINXOPTS = -D latex_paper_size=$(PAPER)
sphinx-%:
$(AM_V_at)test -n "$(SPHINX_BUILD)" || { echo " *** sphinx-build is not available"; exit 1; }
- $(AM_V_GEN)PYTHONPATH=$(DESTDIR)$(pyexecdir) LD_LIBRARY_PATH=$(DESTDIR)$(libdir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) $(top_srcdir)/src/python-systemd/docs $(top_builddir)/man/python-systemd/
- $(AM_V_at)echo Output has been generated in $(abs_top_builddir)/man/python-systemd/
+ $(AM_V_GEN)PYTHONPATH=$(DESTDIR)$(pyexecdir) LD_LIBRARY_PATH=$(DESTDIR)$(libdir) $(SPHINX_BUILD) -b $* $(SPHINXOPTS) $(top_srcdir)/src/python-systemd/docs $(top_builddir)/docs/python-systemd/
+ $(AM_V_at)echo Output has been generated in $(abs_top_builddir)/docs/python-systemd/
destdir-sphinx: all
dir="$$(mktemp -d /tmp/systemd-install.XXXXXX)" && \
@@ -3850,7 +3850,7 @@ doc-sync: all destdir-sphinx
gtkdoc-rebase --html-dir=docs/gudev/html --online
rsync -av --delete docs/gudev/html/ --omit-dir-times $(www_target)/gudev/
rsync -av --delete-excluded --include="*.html" --exclude="*" --omit-dir-times man/ $(www_target)/man/
- rsync -av --delete --omit-dir-times man/python-systemd/ $(www_target)/man/python-systemd/
+ rsync -av --delete --omit-dir-times docs/python-systemd/ $(www_target)/python-systemd/
git-tag:
git tag "v$(VERSION)" -m "systemd $(VERSION)"