summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIvan Shapovalov <intelfx100@gmail.com>2015-02-25 21:47:26 +0300
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2015-02-27 17:28:03 -0500
commitea24d8d1383e038d6b6e599d42c0114b3dbd8acb (patch)
tree5923c51362060964585bfdb17904b30aa114b447 /Makefile.am
parent8a9c6071cb7467170010f0287672c987981bdf9c (diff)
user-sessions: move into own subdir and build independently of logind
Suggested by Zbyszek on IRC. [zj: /run/nologin is used with PAM. systemd-user-session is independent of logind.]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 19 insertions, 18 deletions
diff --git a/Makefile.am b/Makefile.am
index e77a2427c..5847bb4ae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -393,7 +393,8 @@ rootlibexec_PROGRAMS = \
systemd-sleep \
systemd-bus-proxyd \
systemd-socket-proxyd \
- systemd-update-done
+ systemd-update-done \
+ systemd-user-sessions
if HAVE_UTMP
rootlibexec_PROGRAMS += \
@@ -554,7 +555,8 @@ nodist_systemunit_DATA = \
units/initrd-udevadm-cleanup-db.service \
units/initrd-switch-root.service \
units/systemd-nspawn@.service \
- units/systemd-update-done.service
+ units/systemd-update-done.service \
+ units/systemd-user-sessions.service
if HAVE_UTMP
nodist_systemunit_DATA += \
@@ -607,7 +609,8 @@ EXTRA_DIST += \
units/initrd-udevadm-cleanup-db.service.in \
units/initrd-switch-root.service.in \
units/systemd-nspawn@.service.in \
- units/systemd-update-done.service.in
+ units/systemd-update-done.service.in \
+ units/systemd-user-sessions.service.in
CLEANFILES += \
units/console-shell.service.m4 \
@@ -2123,6 +2126,13 @@ systemd_update_done_LDADD = \
libsystemd-shared.la
# ------------------------------------------------------------------------------
+systemd_user_sessions_SOURCES = \
+ src/user-sessions/user-sessions.c
+
+systemd_user_sessions_LDADD = \
+ libsystemd-shared.la
+
+# ------------------------------------------------------------------------------
systemd_shutdownd_SOURCES = \
src/shutdownd/shutdownd.c
@@ -5907,15 +5917,8 @@ endif
noinst_LTLIBRARIES += \
libsystemd-logind-core.la
-systemd_user_sessions_SOURCES = \
- src/login/user-sessions.c
-
-systemd_user_sessions_LDADD = \
- libsystemd-shared.la
-
rootlibexec_PROGRAMS += \
- systemd-logind \
- systemd-user-sessions
+ systemd-logind
loginctl_SOURCES = \
src/login/loginctl.c \
@@ -6015,8 +6018,7 @@ dist_pamconf_DATA = \
endif
nodist_systemunit_DATA += \
- units/systemd-logind.service \
- units/systemd-user-sessions.service
+ units/systemd-logind.service
dist_systemunit_DATA += \
units/user.slice
@@ -6040,8 +6042,7 @@ INSTALL_DIRS += \
$(systemdstatedir)
MULTI_USER_TARGET_WANTS += \
- systemd-logind.service \
- systemd-user-sessions.service
+ systemd-logind.service
SYSTEM_UNIT_ALIASES += \
systemd-logind.service dbus-org.freedesktop.login1.service
@@ -6070,8 +6071,7 @@ EXTRA_DIST += \
src/login/logind-gperf.gperf \
src/login/71-seat.rules.in \
src/login/73-seat-late.rules.in \
- units/systemd-logind.service.in \
- units/systemd-user-sessions.service.in
+ units/systemd-logind.service.in
# ------------------------------------------------------------------------------
if HAVE_PYTHON_DEVEL
@@ -6596,7 +6596,8 @@ LOCAL_FS_TARGET_WANTS += \
MULTI_USER_TARGET_WANTS += \
getty.target \
- systemd-ask-password-wall.path
+ systemd-ask-password-wall.path \
+ systemd-user-sessions.service
SYSINIT_TARGET_WANTS += \
dev-hugepages.mount \