summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-05-20 10:31:04 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-20 17:56:16 +0200
commitea2d9ed42d9896d2ade0dcd5d555c35778c19049 (patch)
treee9ac55be9794baa6067093434f9187c0287b9922 /Makefile.am
parentcfe243e3720062c2e0eecd8bb0bdd7b4059e156d (diff)
units: add services for Gentoo
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6d860ec95..8313e57ff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -132,6 +132,15 @@ dist_systemunit_DATA += \
units/fedora/sysinit.service
endif
+if TARGET_GENTOO
+dist_systemunit_DATA += \
+ units/gentoo/halt.service \
+ units/gentoo/killall.service \
+ units/gentoo/poweroff.service \
+ units/gentoo/reboot.service \
+ units/gentoo/xdm.service
+endif
+
# This is needed because automake is buggy in how it generates the
# rules for C programs, but not Vala programs. We therefore can't
# list the .h files as dependencies if we want make dist to work.