summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTom Gundersen <teg@jklm.no>2014-11-01 14:04:17 +0100
committerTom Gundersen <teg@jklm.no>2014-11-01 15:36:29 +0100
commitf089257d7b573dcff409a5fb0b140fa5c6e4ca84 (patch)
tree9195f3667199b2d75e2892d4813ec2bbd9d0ee25 /Makefile.am
parent5d20fde4a5c4dff4d7c737b545fbd13582d544c1 (diff)
shared: add helpers for unaligend BE read/write
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f1ace0d6..ea4da0b3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -746,6 +746,7 @@ libsystemd_shared_la_SOURCES = \
src/shared/securebits.h \
src/shared/special.h \
src/shared/list.h \
+ src/shared/unaligned.h \
src/shared/macro.h \
src/shared/def.h \
src/shared/sparse-endian.h \
@@ -1347,6 +1348,7 @@ tests += \
test-hashmap \
test-set \
test-list \
+ test-unaligned \
test-tables \
test-device-nodes \
test-xml \
@@ -1625,6 +1627,12 @@ test_xml_LDADD = \
test_list_SOURCES = \
src/test/test-list.c
+test_unaligned_LDADD = \
+ libsystemd-core.la
+
+test_unaligned_SOURCES = \
+ src/test/test-unaligned.c
+
test_list_LDADD = \
libsystemd-core.la