summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-05-20 23:54:59 +0200
committerLennart Poettering <lennart@poettering.net>2010-05-24 23:18:37 +0200
commitf306f4c40d7004be058678ff3ed90c9c006767e0 (patch)
tree310519c04691bb5d0c010d4fc20066e226350200 /Makefile.am
parent723c83fd051e2c3a195251cc0bd1313cb6bcf729 (diff)
units: fix Gentoo services
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bd2523923..a15777e36 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -538,6 +538,14 @@ if TARGET_FEDORA
( cd $(DESTDIR)/etc/init.d && \
$(LN_S) halt reboot > /dev/null 2>&1 || true )
endif
+if TARGET_GENTOO
+ ( cd $(DESTDIR)$(pkgsysconfdir)/system && \
+ rm -f display-manager.service && \
+ $(LN_S) $(systemunitdir)/xdm.service display-manager.service )
+ ( cd $(DESTDIR)$(pkgsysconfdir)/system/graphical.target.wants && \
+ rm -f display-manager.service && \
+ $(LN_S) ../display-manager.service display-manager.service )
+endif
DISTCHECK_CONFIGURE_FLAGS = \
--with-udevrulesdir=$$dc_install_base/$(udevrulesdir)