summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-03-11 07:17:39 +0100
committerMichael Biebl <biebl@debian.org>2013-03-11 07:18:33 +0100
commitf432bb914499e2c28b43f592bb273f0a8664f352 (patch)
tree055b0840d30817c7c2842f835c7ee3de6cff6028 /Makefile.am
parent0876dc1c26b123c3f955e0a34da6ab0375786cea (diff)
Move udevadm to rootbindir
The udevadm utility is needed during early boot, so move it to rootbindir to support split-/usr configurations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 89768e6c3..680dd6597 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1785,7 +1785,7 @@ SYSINIT_TARGET_WANTS += \
systemd-udevd.service \
systemd-udev-trigger.service
-bin_PROGRAMS += \
+rootbin_PROGRAMS += \
udevadm
rootlibexec_PROGRAMS += \
@@ -1871,7 +1871,7 @@ udevadm_LDADD = \
# Update hwdb on installation. Do not bother if installing
# in DESTDIR, since this is likely for packaging purposes.
hwdb-update-hook:
- -test -n "$(DESTDIR)" || $(bindir)/udevadm hwdb --update
+ -test -n "$(DESTDIR)" || $(rootbindir)/udevadm hwdb --update
INSTALL_DATA_HOOKS += \
hwdb-update-hook