summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@inai.de>2014-05-20 23:31:59 +0200
committerLennart Poettering <lennart@poettering.net>2014-05-22 09:27:26 +0900
commitf884afb20674d3d1d223ae300e572a64cdff77f3 (patch)
tree988c040acb17df2a1c8514ad9488754dc9d57004 /Makefile.am
parent52ffb444cbab6fe5680901682f804c051ca624be (diff)
build: put missing KMOD_CFLAGS into Makefile
The build fails if kmod is not in a default location.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1808f801c..e1c86aa73 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4200,6 +4200,10 @@ systemd_resolved_SOURCES = \
src/resolve/resolved.c \
src/resolve/resolved-manager.c
+systemd_resolved_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(KMOD_CFLAGS)
+
nodist_systemd_resolved_SOURCES = \
src/resolve/resolved-gperf.c
@@ -4301,6 +4305,10 @@ systemd_networkd_wait_online_LDADD = \
test_network_SOURCES = \
src/network/test-network.c
+test_network_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(KMOD_CFLAGS)
+
test_network_LDADD = \
libsystemd-networkd-core.la
$(KMOD_LIBS)