summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKay Sievers <kay@vrfy.org>2014-05-22 09:41:32 +0900
committerKay Sievers <kay@vrfy.org>2014-05-22 09:46:09 +0900
commitffcf82d250e95ea0a06a95d7adc72bfad6db51e3 (patch)
tree198dedafc65bc2937b8e0260d8ba0488aec7a137 /Makefile.am
parent5590bbe52985f9f01dbafa740df9c74f2ea95ffa (diff)
build-sys: fix linking order
./.libs/libsystemd-network.a(libsystemd_network_la-network-internal.o): network-internal.c:function net_get_unique_predictable_data: error: undefined reference to 'udev_device_get_property_value' collect2: error: ld returned 1 exit status
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index ac650044b..baf661d63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -190,6 +190,7 @@ AM_CPPFLAGS = \
-I $(top_srcdir)/src/journal \
-I $(top_srcdir)/src/timedate \
-I $(top_srcdir)/src/timesync \
+ -I $(top_srcdir)/src/resolve \
-I $(top_srcdir)/src/systemd \
-I $(top_builddir)/src/core \
-I $(top_srcdir)/src/core \
@@ -2531,6 +2532,7 @@ test_dhcp_client_SOURCES = \
test_dhcp_client_LDADD = \
libsystemd-network.la \
+ libudev-internal.la \
libsystemd-label.la \
libsystemd-internal.la \
libsystemd-shared.la
@@ -4062,12 +4064,13 @@ CLEANFILES += \
src/timesync/timesyncd-gperf.c
systemd_timesyncd_LDADD = \
- libsystemd-label.la \
- libsystemd-internal.la \
- libsystemd-shared.la \
libsystemd-resolve.la \
libsystemd-network.la \
+ libudev-internal.la \
+ libsystemd-label.la \
libsystemd-capability.la \
+ libsystemd-internal.la \
+ libsystemd-shared.la \
-lm
rootlibexec_PROGRAMS += \
@@ -4214,10 +4217,11 @@ CLEANFILES += \
src/resolve/resolved-gperf.c
systemd_resolved_LDADD = \
+ libsystemd-network.la \
+ libudev-internal.la \
libsystemd-label.la \
libsystemd-internal.la \
- libsystemd-shared.la \
- libsystemd-network.la
+ libsystemd-shared.la
rootlibexec_PROGRAMS += \
systemd-resolved
@@ -4299,8 +4303,7 @@ systemd_networkd_wait_online_LDADD = \
libsystemd-network.la \
libudev-internal.la \
libsystemd-internal.la \
- libsystemd-shared.la \
- libsystemd-network.la
+ libsystemd-shared.la
test_network_SOURCES = \
src/network/test-network.c